Change Password Prompt Upon Trying to Log Into Clever

Incident Report for Clever

Resolved

The issue with some users being prompted to reset their password has been resolved. We apologize for any inconvenience this may have caused! Thank you
Posted Dec 12, 2025 - 08:07 PST

Investigating

We are currently investigating an issue where some users are being prompted to change their password when they are trying to log into Clever. We will provide updates as soon as we have them available. We apologize for the inconvenience. For any questions, please reach out to Clever Support at support.clever.com

Thank you
Posted Dec 12, 2025 - 06:12 PST
This incident affected: Single Sign-On.