Error when switching setup sharing view

Incident Report for Clever

Resolved

This incident has been resolved.
Posted Sep 08, 2025 - 10:53 PDT

Investigating

Clever is currently investigating an error when District Admins are trying to switch the setup sharing view when modifying sharing rules for applications. We apologize for the inconvenience this is causing and will post updates as our teams work towards resolving this issue.

Thank you!
Posted Sep 08, 2025 - 07:22 PDT
This incident affected: Rostering API (Events API).