MFA Issues: SMS Codes not generating for Clever Admins

Incident Report for Clever

Resolved

According to Twilio's update, SMS functionality is operational. However, one's connectivity may impact the speed at which the code is received.
Posted Dec 02, 2025 - 09:51 PST

Update

We are continuing to monitor for any further issues.
Posted Dec 02, 2025 - 08:33 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 01, 2025 - 12:40 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 01, 2025 - 10:02 PST

Investigating

At this time, the company that Clever partners with for SMS messages, Twilio, is experiencing SMS delivery issues due to sustained high traffic on the US carrier networks. This is currently impacting Clever Admin’s ability to receive SMS codes for MFA access. We are monitoring the issue and will provide status updates as they become available.

Reference: Twilio’s Status Page (https://status.twilio.com/)
Posted Dec 01, 2025 - 10:02 PST
This incident affected: Single Sign-On.