Pending Staff Deletions
Incident Report for Clever
Resolved
This incident has been resolved.
Posted May 09, 2024 - 07:29 PDT
Investigating
Clever is actively investigating reports of pending deleted staff members across various student information system auto syncs. We’re investigating the issue and will provide regular status updates.
Posted May 09, 2024 - 05:46 PDT
This incident affected: SIS Sync (SFTP / Other, Infinite Campus, Skyward).