Clever Support: Phone service outage

Incident Report for Clever

Resolved

Clever Support's phone provider has resolved the outage and phone service is restored. If you encounter any further connection issues, please submit a support request with our team at support.clever.com.
Posted Mar 31, 2025 - 14:43 PDT

Monitoring

A fix has been implemented by our phone service provider, and inbound calls are now successfully reaching our team. We are actively monitoring the service to ensure continued stability.
Posted Mar 31, 2025 - 11:27 PDT

Investigating

Clever Support’s phone provider is experiencing service issues. We are monitoring the service outage and will provide regular status updates. In the meantime, please submit all support requests via our web form at support.clever.com to ensure our team receives your request!
Posted Mar 31, 2025 - 10:00 PDT
This incident affected: Support.