Some districts are experiencing login errors for all users

Incident Report for Clever

Resolved

The login issue for some districts has been resolved. We apologize for any inconvenience this may have caused.
Posted Jan 08, 2026 - 06:21 PST

Monitoring

Our Engineering Department has implemented a fix and it still closely monitoring the situation. For questions or concerns, please contact Clever Support at support.clever.com.

Thank you,
Posted Jan 07, 2026 - 11:13 PST

Investigating

Clever is currently investigating an issue that is causing some districts to see an error message when users are trying to log into Clever. As soon as we have more information, we will update this status page. We apologize for the inconvenience.

Thank you
Posted Jan 07, 2026 - 07:59 PST
This incident affected: Single Sign-On.